EQ10Q binaries (recommended)

The recommended way of installing EQ10Q plugins is using the installer wizard provided in the link below. These binaries were build using carefully selected versions of libraries that allows the same plugin to run on the LV2 hosts provided by your Linux distribution and Ardour versions provided from ardour.org. To install the plugins just download the installer, add execution permissions to the downloaded file and run it. Using terminal it should be something like this:

chmod +x eq10q_2.2_installer.run
./eq10q_2.2_installer.run

The installer will detect your system architecture (32 or 64 bits) and the gcc version. Then the appropriate binaries of EQ10Q will be installed. Keep in mind that the installer will install eq10q on /usr/local/lib/lv2 and will attempt to detect and delete any previous installations of EQ10Q. However, it is a good practice to check previous installations manually to avoid possible eq10q duplicates in your system.

Click here to download EQ10Q installer

EQ10Q source code

If you are a software packager or you are still interested in the source code of EQ10Q you can get it from sourceforge.net and compile yourself following the README file in the package or the instructions below.

  Click here to download EQ10Q source code

Before proceeding with the build steps, be sure you have the following dependencies installed:

  • Gtkmm (>= 2.4)
    •  a package named like libgtkmm-2.4-dev must be installed
  • LV2
  • CMake (>=2.8.2)
    • cmake package must be installed
  • FFTW3
To build the EQ10Q, first extract the package and mode to the top folder. Then type:
cmake ./
make
make install (need superuser permissions)
This will install EQ10Q on /usr/local/lib/lv2

 

 


Comments are closed.

EQ10Q Donations

Donations helps the EQ10Q project to grow faster. If you like EQ10Q and you want to support it, consider donating some amount.